Gentoo ve KDE4.2 denemesi ?

Gentoo ve KDE4.2 denemesi ?

Mesajgönderen penguenacemisi » 06 Nis 2009, 16:37

Uzunca bir süredir gentoo kullanamıyordum. Bir süre önce 2007.0 gentoo'mu tamamen gözden çıkardım (sistemle çok oynamıştım) ve yeni bir kurulumla netwrokless olarak 2008.0 yaptım. Lakin şuan çok stabil ve hızlı şekilde çalışan KDE3.5.9'umu kaybetmeden 4.2.X e geçmek istedim, şöyle bir bakımdım herkes çok farklı şeyler söylediği gibi çok işe yarar şeylerde bulamadım doğrusu. (şu sıralar rahatsızlığım nedeniyle dikkat dağınıklığım var ben bulamamış olabilirimde).
Acaba deneme amaçlıda olda KDE4 serisinde (özellikle 4.2.x) en rahat nasıl geçebilirim, Şayet başarılı bir kurulum yaparsam elimdeki KDE 3.5.9'dan vazgeçmek zorundamıyım?
Sözün kısası gentoo için KDE 4.2.x e geçiş için nasıl bir yöntem takip edeceğimi kaybedip/kazanacaklarımı biri bana özetleyebilirmi?
(Eğer cevabı forumda varsa özür dilerim, çok bakındım ama göremedim. Rahatsızlığım çok fazla dikkat kaybına neden oluyor gözden kaçırmış olabilirim. böyle bir durumda sadece link vermeniz yeterli olur. yazım hatalarım olmuş olabilir şimdiden anlayışınıza teşekkür ederim.)
Kolay gelsin.
Kullanıcı avatarı
penguenacemisi
Deneyimli Üye
Deneyimli Üye
 
Mesajlar: 338
Kayıt: 17 May 2004, 00:00
Konum: zonguldak/ereğli

Mesajgönderen malzeme_muhendisi » 08 Nis 2009, 22:22

Selamlar, bu forumda daha önce böyle bir konu tartışılmadı galiba. Dikkat dağınıklığından kaynaklanan bir durum yok yani, geçmiş olsun bu arada. :)

Gentoo'da rahatlıkla KDE 3.5.9 ve KDE 4.2.x serisini beraberce kullanabilirsiniz. Tabii derlerken ufak tefek sorunlar çıkabilir, tam olarak bilemiyorum ama onları da çözersiniz. Ayrıca kdeprefix flagini de açmanız gerekecektir.

KDE 4.2 kurmak için size 2 yol önerebilirim. Birincisi Portage içindeki resmi ebuildleri kullanmak. Bu biraz daha sancısız olabilir. Hemen bakalım neler var portage içinde.
Kod: Tümünü seç
purak@hadron ~ $ eix kdelibs
* kde-base/kdelibs
     Available versions: 
   (3.5)   (~)3.5.9!t (~)3.5.9-r1!t (~)3.5.9-r2!t (~)3.5.9-r3!t 3.5.9-r4!t (~)3.5.10-r1!t (~)3.5.10-r2!t
   (4.2)   (~)4.2.1!t (~)4.2.1-r1!t (~)4.2.1-r2!t (~)4.2.1-r3!t
   {3dnow acl alsa altivec arts avahi bindist branding bzip2 cups debug doc elibc_FreeBSD fam jpeg2k kdeenablefinal kdehiddenvisibility kdeprefix kerberos kernel_linux legacyssl lua mmx nls openexr opengl semantic-desktop spell sse sse2 ssl test tiff utempter xinerama zeroconf}
     Homepage:            http://www.kde.org/
     Description:         KDE libraries needed by all KDE programs.


Gördüğünüz gibi kdelibs'in 4.2.1-r3 sürümü var depoda. Bu KDE sürümününde aynı olacağı anlamına geliyor. Fakat bu sürüm ön tanımlı olarak maskeli, aslında 4.2 serisi tamamen maskeli. Eğer arch(yani ~) olarak sistemi ayarlamışsanız sorun yok.Fakat normalse unmask ederek kullanacaksınız. Pek çok paketi unmask etmeniz gerekecektir.
Kod: Tümünü seç
emerge -av kdebase

Komutu yardımıyla kurabilirsiniz.
İkinci yol ise overlay kullanımı. kde-testing overlayini kullanarak KDE'nin en güncel sürümlerine ulaşabilirsiniz.

Çok detaylı açıklamalar ve setlerin kullanımı bu[1] bağlantıda var.
[1] http://www.gentoo.org/proj/en/desktop/k ... -guide.xml
Gentoo
Kullanıcı avatarı
malzeme_muhendisi
Deneyimli Üye
Deneyimli Üye
 
Mesajlar: 447
Kayıt: 26 Tem 2007, 00:00
Konum: cehennemin dibi

Mesajgönderen penguenacemisi » 09 Nis 2009, 08:52

cevabın için teşekkür ederim malzeme_muhendisi ama ztn şuan kde-4.2.1 deyim
sistemimi tamamen güncelledim ve autounmask yardımıylada kurulumu hallettim. Garip bazı sıkıntılar çıktı, Kde 3.5.9 u tamamen kaldırdımki sanırım doğru tercih yapmışım 4.2.1 sürümünü kullanmak şimdilik daha mantıklı geliyor. emerge ederken mysqlin kurulu olan sürümünün güncel sürümü blokladığı görünüyordu ama halbuki mysql daha kurulu bile değildi, tesadüfen kdenin bağımlı olduğu paketlerden biri USE flag'i yüzünden mysqle ihtiyaç duyduğunu, emerge esnasındada (nasıl oldu bi türlü anlamadım) birbirlerinden habersiz ilk istek yapan paket yüzünden kde'nin mysqli kurulu gibi olduğunu düşünerek ilk önce sorun çıkartan bağımlılık paketini bulup onu kurdum, ve sorun halloldu. 256 SDram P3-1Ghz 8MbAti Radeon gibi eski bir notebookta deniyorum, tabi compozite eklentisi için daha uğraşmadım, zira zaten ben yıllardır bu ekran kartımı hiç bi linux sürümüne tanıtabilmiş değilim :). bu donanımla kaynaktan derleme ile gayet iyi çalışıyor açıkçası, en azından ben memnun kaldım (:
Kolay gelsin.
Kullanıcı avatarı
penguenacemisi
Deneyimli Üye
Deneyimli Üye
 
Mesajlar: 338
Kayıt: 17 May 2004, 00:00
Konum: zonguldak/ereğli


Dön Gentoo

Kimler çevrimiçi

Bu forumu gezen kullanıcılar: Hiç bir kayıtlı kullanıcı yok ve 1 misafir

cron